Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
JustFishin.....

Yamaha T9.9 fuel issue solved

Recommended Posts

I recently boat a 1993 Yamaha T9.9ELRR it was starving for fuel and not running correctly. These motors are notorious for fuel pump issues and Yamaha has since developed a pump with a heat sink and cooler for them. I picked up the new pump (around 100 bucks) at Brobiel Marine (Frans a great guy). Replaced the pump and she was running only slightly better and still sucking the filter dry.

 

I ripped out the connections and fuel line and ran a new line straight to the tank. Same thing.......... I read somewhere that a clogged crank breather could cause this issue. I pulled the breather line (see pic 1) and sure enough it was clogged with a mud wasp nest or something. Cleaned it out, checked inside the breather and other lines. Everything is clear and she is running great now. Hope this helps someone out one of these days.

 

 

 

Sent from my iPhone using Lake Ontario United mobile app

 

 

 

Sent from my iPhone using Lake Erie United Mobile App

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...