Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Fishy7816

Starter Problems

Recommended Posts

I think we'll need a little more information here... Are you saying that you need to crank your motor for up to 10 minutes before it starts?

And what kind of motor are you talking about?

Sent from my XT1635-01 using Tapatalk

Share this post


Link to post
Share on other sites

If it's cranking and not firing, the first think I would say is change the plugs (2 strokes need a little TLC)

If it's not cranking over, check all of your battery connections and make sure their clean.

Sent from my XT1635-01 using Tapatalk

Share this post


Link to post
Share on other sites
If it's cranking and not firing, the first think I would say is change the plugs (2 strokes need a little TLC)

If it's not cranking over, check all of your battery connections and make sure their clean.

Sent from my XT1635-01 using Tapatalk


Thanks so much- will do. Hoping to be out a lot this weekend.

Sent from my LM-X210CM using Lake Erie United Mobile App

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...